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Installation and Licensing

System requirements:

Adobe Acrobat Professional version 7, 8 or 9 is required on each Cockpit workstation. There is
no longer support for Acrobat 6; Acrobat 9 is supported with4.0 SP2 and higher.

Supported operating systems for Cockpit workstations include:

–Windows 2003 Server (SP2)

– Windows 2003 Server R2 (SP2)

– Windows Vista Business

– Windows XP Professional (SP2)

– Mac OS X v10.4.11 or higher (Tiger)

– Mac OS X 10.5.2 or higher (Leopard)

Hardware requirements have not changed from the previous version. 2GB of RAM and Gigabit
ethernet are very strongly recommended.

For full functionality and compatibility, Prepress Manager requires compatible versions of all
connected software; i.e. Prinect Signa Station 4.x, PDF Toolbox 4.x, Prinect MetaDimension 7.x
and Prinect MetaShooter 4.x.

New Licensing Options

Certain new features in Prepress Manager are licensable options. These include:

– Versioning and the VersioningAssistant Plugin (single or site license)

– Coating Editor for on-the-fly creation of varnish plates (single or site license)

– Prinect Archiver for archiving to DVD, Disk or Tape from any PC workstation
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One Installer for All Components

The new installer has been simplified. Except for the Oracle Common Database, all compo-
nents for a complete Integration Manager are always installed. Licensing determines what can
be used. Only Engines with a valid license will start.

All Cockpits are now Production Cockpits; there are no separate Prepress Manager or
Pressroom Manager Cockpits. User permissions control what a user sees and can use. Later
this year a View Cockpit will also be available.

The Cockpit extensions (located in PTConfig\CockpitExtensions) are loaded depending on
what user rights have been assigned to the login user. These extensions are for things like Con-
tent Manager, Change Requests, Press Presetting and Reporting and Scheduling.

General Cockpit Changes

Improvements in Launching

When Cockpit launches it now shows a progress bar across the bottom of the splash screen. If
there is a problem you might be able to tell which component is causing the problem. A good
example might be if the MDS does not respond, you will see that in the progress bar, and be able
to terminate the launch.

Unreachable servers will no longer slow the Cockpit start down.All computers that the Prepress
Manager recognizes are listed under Administration \ System \ Cockpit. You can see the
computer and status listed under the server list.



If the workflow includes Data Terminals which require that a user
have a unique Employee ID number, that number can now be
entered directly in the Create User dialog box. It is no longer
required that you go into Properties to create this ID.
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Improvements in Job Handling

When you initiate certain types of processing on a job, you will be offered the option to Run in
Background. This will allow you to continue working while the job processes.

The Jobs list and it’s display has been significantly improved in version 4. Jobs are now dis-
played more quickly and the job list response is almost instantaneous when changes are made.
The need to have jobs grouped in small groups of 100 jobs or less is eliminated. There is now no
restriction on the number of jobs in a group; in fact organizing jobs in groups is now totally
optional. For this reason the New Group button is missing from the Jobs List window, and is
only available under the File Menu.

Changes in Administration

Users

User management has been somewhat simplified in that there is now an option to use the same
password in Cockpit as the workstation operating system uses. This means that when pass-
words are required to change every 90 days for example, it is no longer necessary to also
change it in Cockpit. It will be automatically recognized. The same user name and password that
exists in the operating systemmust be used when you login to Cockpit.

To use this feature simply enable the Password for OS Login check box when you create a
new user.

In the User Properties it is possible to select a language to be used with this account. So in
theory different users could use different languages in the Cockpit based on their login.



Preferences

In addition to the Output Profile, you can now specify a Process Standard in Preferences
under the Default Job Settings section. This process standard will then be included in the Job
Settings of every job created. The process standard would need to be created in Color Toolbox
and saved in the MDS, then it would be available for assignment here. Prepress Manager can-
not manage the process standard information.

There is also a new preference in the Warnings section that will generate a warning when a
submitted sheet contains pages that have not been through a Prepare sequence. This warn-
ing is activated by default.

Planned Tasks

The new Planned Tasks tab allows to you to schedule certain job-related tasks that either
need to repeat, or need to happen at a certain time. The Timer Enginemonitors this scheduling
and forwards the instructions to the appropriate application; i.e. Cockpit Server, the Message
Service, etc. No special license is required to take advantage of the scheduling function; how-
ever, only users with Administrator permissions have the right to create and manage the tasks.

The following types of tasks can be created:

– Migrate Jobs – This will perform the migration of the job JDFs after an update process.

– Archive Jobs – Based on certain job states and time lapses, jobs can be scheduled to
automatically archive. You can control when the archive process starts, how long it should
run, and which sequence template should be used.

– Stop Jobs – Jobs that have been inactive for a certain length of time, or whose due date
has been exceeded by a certain amount of time can be stopped and their status changed
to finished.
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Other types of requests controlled by the timer include a followup email regarding approval due
times or approvals past due.

Resources

Color Tables – New color tables have been added. The 2006 Pantone tables are deactivated
by default. A warning can be set in the Preflighter to warn or stop jobs if old style Pantone color
names are included in the files. You can now activate or deactivate a color table simply by using
a check box.

Preflight Profiles – Profiles that are created in PDF Toolbox can now be imported and used in
Cockpit. Default profiles are already included with the installation, as well as previous Enfocus
Pitstop profiles. Profiles from Pitstop are designated with a .ppp extension and are displayed in
red; profiles from Heidelberg’s preflighter are designated with a .hpp extension and displayed in
blue. PitstopAction Lists have the file extension of .eal and are displayed in green.

Profiles made in PDF Toolbox are stored in the following locations:

Windows – C:\Documents and Settings\All Users\Application Data\Heidelberg\PDF Tool-
box\PreflightSets

Mac – Users\Shared\Heidelberg\PreflightSets

To be used in Cockpit, they should be copied to PTConfig\SysConfig\Resources\Preflight-
Profiles; or you can use the Import function from the Preflight Profiles tab to import them.
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External Hotfolder

A new entry in the System tab allows you to specify an External Hotfolders Location. This
allows employees who are not Cockpit users and do not have permissions in the Prepress Man-
ager environment to use hotfolders and drop files for Prepress Manager jobs.

To use this function, define a shared directory in the environment where the external hotfolders
will be located. Be sure the correct permissions are assigned to this location. Define this location
(via UNC path) in the External Hotfolders Location box in the System tab. Restart the Con-
tentHotFolder engine after you do this. You can then activate the use of this external hotfolder
in theQualify sequence. See Changes to Sequence Templates later in this document.

To insure error-free communication and be sure the hotfolders are always available, the com-
puter where the hotfolders reside should be made part of the Prepress Manager neighborhood.

Changes in Queues

Queues can now be shown or hidden as desired. Deselected queues will not be visible in the
list. From the Queues view, choose View > Filter Queues... to see a list of all queues. Uncheck
the ones you do not wish to see in the list and click OK. Use the View > ShowAll Queues option
to once again display all of the queues in the list.

6 Prinect Prepress Manager v4.0 – Print Media Academy



If you right click in theQueue window, you can display the queues by cluster; for example all
queues (engines) that can create varnish.

Changes in the Jobs List View

Many visual and functional changes have been made to the Cockpit Jobs List view.

– NewGrouping Table provides new sorting and filtering options.

– New column sets.

– Empty directories (groups) appear dimmed in the list.

– New Group button is gone; it exists only under File > New > Job Group... or by using the
shortcut Ctrl + G.

–Menus in the Job List view now show only entries that can be applied in the job list.

–Menus in an open Job window show only entries that can be carried out in the open job.

Column Sets

Due to the improved search and filtering capabilites, there are two new default column sets. The
first is Classic, and displays the group and job view that we are all used to.

The new Flat list set shows a flat job list, without reference to any group or job home location.
Be aware that if you delete jobs from this view, the corresponding group will not be deleted.
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In either view if you hold down the Ctrl key and select a column, you can further define several
sorting criteria. A little number will appear in the column showing the defined order.

Grouping Table

The new Grouping Table allows sorting according to any desired columns and attributes.
This makes the interface and job list very adaptable and flexible, and the results are instant.
Sorting starts from left to right and you can drag and drop any column to any desired position.

For example, to sort jobs by Customer, start with the Flat List column set view. Activate the Cus-
tomer Name column if it is not already active. Then click on the Customer Name column head
and drag it to top grouping position. Jobs will immediately be grouped in the list according to
their customer name. Note that a customer name must have been assigned to the job(s).

To further categorize the jobs by Due Date, click the Due Date column head and drag it up to the
Grouping Table area. The job list now further divides under each customer by the job due date.

8 Prinect Prepress Manager v4.0 – Print Media Academy



Print Media Academy – Prinect Prepress Manager v4.0 9

You can drag and drop as many column head sorting criteria as you wish and place them in any
order. Results are displayed instantly. If you decide to remove a criteria, simply drag and drop it
back to the column head position.

Instead of the drag and drop method, you can also just right click on a column head to select
and group it, or right click on a grouping to remove it. Also by right clicking in any column head
you can access the customize menu to select or deselect column heads to be displayed.

Navigating the Grouping

Using the contextual menu, you can Collapse All groups, or Expand All. Pressing the arrow
keys will also navigate through the group list. The up and down arrows will scroll through the
group structure without opening or closing anything. The right arrow on a closed group will open
it; the right arrow on an open group will select the entry below it. The left arrow works in just the
opposite way.

Filters

The new fast filter replaces the previous filter dialog interface. The entire job list can now be fil-
tered in almost any way desired. Filtering is done similar to the way the grouping table is defined.
Drag and drop a displayed column to the first filter field above the jobs list. Additional filters are
added by dragging the desired column and adding it to the existing filter. Filter sequence is
always left to right. Certain columns such as Job Flags, Workflow Status, Job Status and Due
Date can not be filtered, but all except Workflow Status can be used as grouping criteria.

Multiple Custom Column Sets including Grouping and Filtering criteria can be saved.

This Grouping table and Filtering criteria capability has been implemented in many windows and
views of the Cockpit.



Changes in the Job View

The tab formerly called Elements has been split into two tabs – Prepress and Press.

Product Description

In the Product Description tab of a job, you can create the versions required for versioning jobs.
You can specify the master version (red icon) or multiple language versions (green icon).
Createmultiple subproducts (blue icon), or create special Product Intents.

Job Settings

UnderColors, in the Target column there is a new option toOutput per Version. This is used in
conjunction with the new Versioning 2008 features.

Under Printing Process on the Job Settings tab, you can specify an Output Profile and a
Process Standard. The Prepress Manager will then do a Consistency Check to make sure that
the Paper, Profiles, Calibration Curves, Plate Formats, etc. are consistent with each other. Cus-
tom Process Standards can be created in Color Toolbox and assigned here.
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A New Output Profile called HDM Offset 2007 is supplied. This profile belongs to the new
process standard called HDM_BB. This is based on Fogra 39 (white backing), but also
accounts for the black backing that Heidelberg color measuring devices require.

Prepress Tab (formerly Elements)

The Grouping Table functionality has been applied to the Pages view here also. You can group
by Product, Version, or Assign Count. To retain the view of previous versions, activate the
Assign Count option.

View Properties

This is accessed by right clicking on one of the page thumbnails, or can also be accessed when
you select a layout. From here several new functions are available. These can be set differently
for each user.

– Choose to Show or Hide the Status Icons beside the thumbnails.

– Choose to Show or Hide the Trim Box and specify the color that should be used to dis-
play the Trim Box (for pages only).

– Specify the preferred Thumbnail Size by using the slider bar. Choose from 0 to 250%.

– Choose to Show a Grid and specify the color that should be used. The thumbnails will be
shown in a grid format and a selection can be made by simply clicking inside the grid.
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Page Geometry

In the contextual Change Page Geometry dialog box there is now an option to use a user
defined page offset, rather than only using the Trim Box. If you change parameters here, you
can see in the list view that the designation is shown in Bold face type and states By User. If the
Trim Box is used in the Change Page Geometry dialog box, then the Rotation options will be
grayed out. You must choose User Defined to be able to change the rotation of a page.

Page Properties

Getting Properties on a page will now show the results beside the Thumbnails. Different sub-
menus of the properties are displayed on different tabs; i.e. Properties, Saved Versions, and
History. History can be easily viewed on single elements in this way. This is also a convenient
way to find and open the Preflight Report that is automatically generated on all files.

Layout List View

The List View for Layouts now only opens to the Surface level. Page positions and assign-
ments are shown in the Properties window. Different categories are shown in tabular format
within the Properties. You can view Properties, Colors, Materials and History.



Print Media Academy – Prinect Prepress Manager v4.0 13

Layout Thumbnail View

Depending on the settings in View Properties, the thumbnails for several sheets can be shown
side by side across the window. Front and back of a sheet will never be separated. The Front
and Back of a sheet now show a yellow and green designation as in Prinect Signa Station.

Sheets

The Sheets category is no longer shown in the Prepress tab. Sheets are now displayed in the
Press tab for the PressroomManager.

Changes to the Sequence Templates

Qualify Sequence

External Hotfolder – If a directory has been defined in the Administration > System tab as pre-
viously discussed, the External hotfolder location can be activated in Qualify. Users can then
drop files for processing into this external folder location.

Normalizing – The Normalizer library is updated to the version of Acrobat 8.1. The content of
the Normalizing section has been re-organized in a tabular format for easier navigation.

Split Document – You can now specify a number of pages per file when splitting documents.As
before, you should use this option with caution as it increases processing overhead.

Preflight – The Preflighter is completely revamped and is now a Heidelberg developed tool.
Over 81 checks can be implemented. The Preflighter section is reorganized in tabular format for
ease of navigation. Sections include Actions, Document, Pages, Images, Fonts, Colors and
Content. Preflight report summaries are automatically generated on each file processed. You
can generate custom Preflight Profiles in PDF Toolbox, then import and use them in Cockpit.
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Prepare Sequence

Several new functions are available in the Prepare sequence. Like in the Qualify sections, most
sections in Prepare are reorganized into a tabular format.

Varnish – If licensed, this options allows for on-the-fly creation of varnish plates. Capabilities
are similar to those found in the PDF Toolbox Coating Editor plugin.

PDF Optimization – This aid to preparing files for repurposing allows you to clean up unwanted
objects and comments in a file; as well as convert text to graphics. You can also resample and
compress images.

Versioning – If licensed, this new processing step aids in splitting and checking files as a step in
the preparation for creating versioned output.

Color Conversion – Includes advanced options for use of Device Link profiles and for applying
overprints and knockouts.

CopySurface PDF Sequence

A new sequence used especially with Remote Access to copy high res pages to the Exchange
area of the RAserver.

Assemble PDF Sequence

Now also includes all of the options contained in the PDF Optimization section of Prepare.

Send Assembled PDF Sequence

You can now specify the latest acceptable response time, and then have the system send a
reminder email message if no response has been received by the specified time.

Impose PDF Sequence

Proof Color can now be set to knockout. Marks can be output on proof at a lower dot area %.

Job Export Sequence

Now includes a new Subcontractor section. This is intended for jobs exported and sent to other
vendors who use Prepress Manager. They can import the jobs with more complete information.
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