Standard Finishing
4Over

Announcement

Collapse
No announcement yet.

Can't Log in to Admin Account - Any thoughts?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Log in to Admin Account - Any thoughts?

    G4 Powerbook running 10.4.11

    I made a second user account on my machine a few days ago with limited user capability. The account was basically setup as a simple internet user station with limited access to applications, no access to preferences, and no access to the utilities folder.

    Processing had slowed way down so last night I logged out of both users (Admin and Guest) and restarted the machine. Start up proceeded as normal till it got to the log in screen and the only account available was the guest. I logged into the guest user thinking I could then switch users (I set the preference for the machine to not automatically log in as Admin at startup). No deal, tried to go back to the login screen and the guest user was still the only visible account. And just to compound the problem the apps don't work right now when logged in as Guest. the help viewer is hosed. I can search topics but when I click on a topic it takes me back to the opening screen so I couldn't access any of that. The internet works on it but it's slowed down to a crawl, practically unusable, pages only load about 25% of the time otherwise they time out. So I had to wait till I got to work this morning to post this.

    So far the only things I've tried are what little keyboard options I have at startup, I zapped the Pram but all the other functions seem to be disabled as well. I have not started up from a disk yet. I couldn't find the install disk last night so I'm going to scavenge one from here hopefully.

    Anybody have any thoughts on what happened to the Admin account, why it's no longer visible, and what I can do to restore it?

    Thanks in advance.

    Edited by: Slowpockets on Dec 4, 2007 7:49 AM

  • #2
    Re: Can't Log in to Admin Account - Any thoughts?

    My guess is that you inadvertently "hid" that user login when you made the new account. Do you see a user named "other"? If you do use your login info by selecting "other". BTW you can fix this by typing this into Terminal application

    sudo defaults write
    /Library/Preferences/com.apple.loginwindow HiddenUsersList -array-add

    Comment


    • #3
      Re: Can't Log in to Admin Account - Any thoughts?

      Thanks for the reply.

      No isn't any other account at the login screen other that guest, and unfortunately I didn't allow access to the Utility applications (or the system preferences) so I can't use terminal. I wonder if there is another way to set account permissions from within the guest account so that I can get into the utility apps. Last night as I was getting frustrated I just started shutting down and starting up a few times. At one point a window popped up while I was shutting down that said there were processes running and I had to verify the shutdown by entering my admin name and password, which apparently worked.

      Comment


      • #4
        Re: Can't Log in to Admin Account - Any thoughts?

        Ok quick fix time. Log in to the other account you made. Open system preferences. Click on Accounts. Click on Unlock login options, and when asked type in your admin username and password, and now you are in. You can now change the login options to show your account if it's still present, if it's not present post back.

        Comment


        • #5
          Re: Can't Log in to Admin Account - Any thoughts?

          And there lies the problem, I have zero conventional access to the system preferences. I can't open system preferences from the guest account. I didn't set up the guest account to have any access to system preferences. When I try to open system preferences from the guest account I am presented with a message that says, and I'm paraphrasing here "Guest account does not have permission to use system preferences, please contact the administrator" <--- that's me :0)

          The exact same thing goes for every application in the Utilities folder. If it's an application in the utility folder I can not access it from the guest account. And the guest account is the only user account available at the log in screen.

          I will say however that when I go to the hard drive - users - my user name, I can see all the folders and files that are under my account I just can't access them. So that seems like a good sign, at least the machine recognizes that the data is there.

          Comment


          • #6
            Re: Can't Log in to Admin Account - Any thoughts?

            Cool so you didn't delete you user then.
            Check out this thread at Apple's forum for more help.
            http://discussions.apple.com/thread....754&tstart=210

            Comment


            • #7
              Re: Can't Log in to Admin Account - Any thoughts?

              Nice! That looks exactly like my problem. Thanks for the help man.

              Comment

              UltimateDuploSmartsoft (Presswise)Standard FinishingKBA4Over
              UltimateDuploStandard FinishingKBAKBA GTIChili publish4Over

              What's Going On

              Collapse

              There are currently 5704 users online. 152 members and 5552 guests.

              Most users ever online was 6,151 at 11:36 AM on 11-17-2017.

              Working...
              X