Standard Finishing
4Over

Announcement

Collapse
No announcement yet.

Developer gears and rollers crust

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Developer gears and rollers crust

    Developer Gears and rollers are getting hard deposit buildup on them within a couple of weeks. It did not used to be this way. I can't think of anything that would cause that. We have changed our supplier a while back but I don't know if that would be it or not. I thought developer was developer. Is it not all the same formula no matter where it comes from? It is DOT WORKS 650 Majestic Rapid Access Developer.

    Or maybe temperature and time might have something to do with it. Thanks for any suggestions or if anyone has seen anything like this before.

  • #2
    Are you doing weekly or fortnightly cleaning?
    Asif Qazi
    www.facebook.com/printindustry

    Comment


    • #3
      I guess you refer to a Rapid Access film processor.
      From long experience (over 30 years) of using automatic film processors with all kinds of films and chemistries, I can sum that hard crusty deposits are building up in the Fixer section only.
      In the Developer section you can expect to get thin black deposits of metallic silver.
      In the Water section you may get Brown slippery slime (algae buildup) within days, depending on wash water quality (and quantity).
      Routine cleaning is mandatory, frequency should reflect quantities (sq/m area) of films processed.
      Some combinations of film and chemistry tend to create deposits faster then others.
      Your new problem should be solved by the supplier of your film and chemistry, since compatible combination should not build up heavy deposits in the Dev or Fix sections for at least a couple of weeks.

      Comment


      • #4
        All film processors I know of are designed to remain on all the time. They are programmed for the rollers to turn/rotate periodically, maybe a minute every quarter hour. That keeps the build up from happening. Primarily seen on the developer rollers and gears .

        Are you sure that something hasn't happened to the program of the processor that prevent it from coming on occasionally to turn the rollers? Is the power left on to the processor 24/7/365?

        Comment


        • #5
          Very true for Plate Processors, unlikely for Rapid Access film processors.
          In the old days, Lith film processors HAD to be left ON 24/7 for periodic Anti-Oxidation replenishment so that developer effectivity and stability will be preserved.
          "Jogging" the rollers may have come in as a bonus.

          Comment


          • #6
            I've cleaned my share of various film processors, and I agree with Repro Pro. However, I have seen crusty stuff in the developer section a time or two.

            Ask your supplier. It's possible that you got some really old developer that perhaps is tending to evaporate more rapidly.

            It is possible that the developer got contaminated somehow? That could cause a reaction and maybe some crust.

            Comment

            UltimateDuploSmartsoft (Presswise)4OverStandard FinishingKBA
            UltimateDuplo4OverStandard FinishingKBAKBA 4Over

            What's Going On

            Collapse

            There are currently 4698 users online. 108 members and 4590 guests.

            Most users ever online was 6,151 at 11:36 AM on 11-17-2017.

            Working...
            X