avantra 25 olp problem

fourstate

Member
we purchased a avantra olp for our machine i was told it was working when they removed it a year ago. when i turn it on it goes through the system check and then the screen goes blank like normal but i cant get it to power on and the buttons dont beep when pushed, i tried my other control box that didnt help, all fuses good, the battery on the board was bad and i replaced it but still nothing. thanks
 

Slammer

Well-known member
we purchased a avantra olp for our machine i was told it was working when they removed it a year ago. when i turn it on it goes through the system check and then the screen goes blank like normal but i cant get it to power on and the buttons dont beep when pushed, i tried my other control box that didnt help, all fuses good, the battery on the board was bad and i replaced it but still nothing. thanks

Working a year ago..? Well that could be true, perhaps, perhaps not. Check all cables and connectors, sometimes they get knocked off or are loose or even corroded. Apart from that have a look at the powerdistribution board.
 

maxon

Well-known member
Check top cover is detected, reed relays actuated by magnets on cover if I remember correctly.
Inspect cable going to the control panel but never remove those connectors when machine is powered on, that cable carries some supply voltages and disconnecting the live cable usually damages the main computer board or at least blows a fuse.
The silver membrane keyboards used to fail very often, most times it's the flat cable going from keys into the panel PCB connector corroded just near the connector - get a handheld multimeter and check continuity on all silver traces there.
 

What About Profitability?

Canon
What about Profitability?
Offset yields new advantages

Read All About It

   
Top