Ptr4300 Servo unit does not enter the "Ready" status


Active member
Hi guys

How to solve the problem:
E0127 - Servo unit does not enter the "Ready" status.

2 years few times per day Ptr4300 gave error: E0127 - Servo unit does not enter the "Ready" status.
Finally after executing: Adjust offset from Input parameter/Drum parameter screen, this error reached after initialization of the platesetter and after every command from Drum menu.
Sucessfully is executed only Adjust offset command.
Last edited:
Check the electrical connections in the block on the home side panel, bottom left and make sure they are tight.
E0127 indicates a problem with drum positioning. Could be a problem with main rotation motor, servo pack, APIO or relay problem.
Thank you, Greg

I look at the same direction. When I try to execute Go to Leading Clamp position, motor are going to some position, but reaching wrong one.
Check the Servo Pack Status at the moment of error appearing (Inpit Parameter ->Drum Parameter ->Status red) and make a picture. This data can help to diagnostic.
Also check tension of the main belt between motor and drum. If the belt vibrates at some moments (loading or unloading plate etc.), you need to increase tension or replace the belt.
Hi Aleksey

I already ordered a new belt. The old belt vibrates all the time, but not too much.
Interestingly all of this happened after the Adjust Offset procedure.
Current status after error is 850A - 0099.
Here is the picture too. 20150428_154855.jpg
Seems something overloads the servo.
yes, but other errors inform about undervoltage and encoder error.
If belt replacement will not help, better way for diagnostic - check servo pack and motor on other CTP (if it possible for you).
Mr Ramirez, please explain again a bit more about "Tune" on Pio and A0.
Without initialization from service menu Drum rotating Slow with no error but too big vibrations in the belt. Belt tension is ok. I can order motor, but maybe the problem is in the servo pack?
Looks like servo pack have not integral correction (because of vibrations). Or differential correction is too big?
Again all this happen after setting the Offset of drum.
Hi guys,

Some new results (machine still not working).
1. Servo work well in speed mode (slow and fast rotation).
2. Every operation in positioning mode finished with "Servo does not enter the Ready status.
3. Servo after every positioning operation send hardware signal Ready. It's mean that PIO board use more information. This can be info from drum encoder.
4. After every positioning operation servo positioned drum in wrong position.
5. Time to time servo does not execute speed and positioning commands.
6. After changing the motor, vibrations are disappeared but positioning is still wrong.
7. Initialization of the servo is successful but setting of Offset and Gain still not successful.
8. On oscilloscope signals from drum encoder measured in the input of the PIO board looking good.

Some idea why after Offset and Gain ctp stopped work. If there is some problems in rs232 communication between RSP and servo, setting of Gain and Offset is unsuccessful. Here is question why setting of Zero position is unsuccessful too.
Bad thing is that no way to say - Servo or PIO or RSP or encoder is defective without checking all them on other machine. But there is risk do damage something on other machine.
Finally the problem solved. The Machine working seamlessly.
It's hard to explain here all details because of a lot digging and reading.
With few words. Motor has changed without big success. Final result was reached after changing some parameters of servo.
All errors disappeared. If somebody have the same or similar problem can write me private message.


A 30-day Fix for Managed Chaos

As any print professional knows, printing can be managed chaos. Software that solves multiple problems and provides measurable and monetizable value has a direct impact on the bottom-line.

“We reduced order entry costs by about 40%.” Significant savings in a shop that turns about 500 jobs a month.

Learn how…….