PSL Jetletter wont install properly.


New member
Hello everyone,

Recently we upgraded our PC that uses PSL to windows 10 which ended up breaking a few of the setups we use. They work fine for our other guy with PSL but its a pain to have him run them so normally I do. Someone in the shop suggested uninstalling and reinstalling so I did the following instructions for doing so. They are as follows

-If PSL is installed on PC
--close PSL
--uninstall PSL
-run PSL setup file v4.0
-reboot PC
-start PSL
-click on – Options
-select – Activate License
-cut and paste the above Serial #

After doing all of the above PSL Wont open on the windows 10 machine. As a test I used the same installer on one of our windows 7 machines and it worked just fine.
The PSL Version is 4.07(Yes I know its old)
I'm curious if anyone else has had this issue before or if I need to bite the bullet and buy the newest version.


Well-known member
Have you tried running it in a compatibility mode? Right click the program or shortcut, click "Properties", then mess around in the "Compatibility" tab.


Well-known member
What do you think of PSL? I got a demo of it and was less than impressed with the demo. We use Xmpie and I felt like we would be taking a step back going to PSL. I am waiting on them to get me the demo version of the software to play with. Our customers send us print ready artwork most of the time, it didn't look like PSL was geared towards using that.


Well-known member
Does it just sit there and hang after you activate your serial #? If so, I've had issues with that as well, but I contacted support and got it resolved.


A 30-day Fix for Managed Chaos

As any print professional knows, printing can be managed chaos. Software that solves multiple problems and provides measurable and monetizable value has a direct impact on the bottom-line.

“We reduced order entry costs by about 40%.” Significant savings in a shop that turns about 500 jobs a month.

Learn how…….