Epson 7800 driver error - close to defeat

Epson 7800 driver error - "Command Error - Check Driver Settings" & "Incorrect Printer Driver Settings"

Hi all, I bought myself a new (second hand) Epson 7800 and I ran a nozzle check when I got it and all of the colours came through fine so I thought it was a go. Now that I have it in my office I can't get it working so I hope by sharing my plight someone will be able to help.

I already have another Epson 7800 at home so I know how to operate them. I bought a new laptop and a new PC for my office as well as two other large format printers (Epson 7880 & 7890) which both work fine. I installed the driver onto my PC for the 7800 and the Epson monitor came up and told me how much ink I had so it has obviously connected and is communicating but then when I go to print I get an error on my computer saying "incorrect printer driver settings" and on the printer saying "command error check driver settings".

Here is a list of the things I have tried to get this working.

reinstalled the driver on my PC

Installed the driver on my laptop

Reinstalled the driver on my laptop - my laptop works fine with the Epson 7800 driver on my printer at home but not this printer.

Used different USB cables - I have two working printers so I used the cables that were working on those printers.

Disabled Epson monitor 3.

Changed the inks and the paper.

Changed the USB connection on my computer.

Downloaded the Epson Front Panel software and reinstalled the firmware multiple times.

Checked that the correct ink is selected - printer has Photo BLK installed and I am printing with Photo BLK.

I took my laptop home and it works fine with the 7800 I have there so there should be no reason why this one isn't working other than the firmware but I have checked that. Really struggling to think of other solutions so I'm hoping someone one here will have an idea.

Laptop and Desktop both run Windows 10, PC has i5-6400 and laptop has i57200 processors both with 8 gig of ram.

Thanks in advance,

Lorenzo lab guy

Well-known member
When we used to have connection problems with epson X500 and X800 printers we would switch from ethernet to usb. I wonder if you tried installing it as network printer instead of usb you might be able to do an end-around the problem.
I think you have eliminated this but older drivers can fail because of not conforming to windows 10 requirements on signing.
Last edited:
Thanks for the response Lorenzo. I haven't tried the printer with the network because this printer doesn't use ethernet it uses firewire which I have no means of connecting with to test it out and I'm not entirely keen on purchasing and installing a firewire adaptor to my motherboard to find out whether that would work. Because I am getting the ink levels I can see that the connection is there through USB so I just can't fathom it.

I have tried downloading various drivers for different windows editions to see if it is a problem with the type of driver and that didn't work. I will have a check to see if there is a firewire to USB converter that I can get to test the network.


A 30-day Fix for Managed Chaos

As any print professional knows, printing can be managed chaos. Software that solves multiple problems and provides measurable and monetizable value has a direct impact on the bottom-line.

“We reduced order entry costs by about 40%.” Significant savings in a shop that turns about 500 jobs a month.

Learn how…….