Read if you want a fix: Frozen Screen on Xerox DC240, 242, 250, 252, 260


Active member
Hi guys, I know this topic may be irrelevant to most out there however if you have Xerox Digital press, the following should apply.

Now I know technology has moved on since the birth of the Xerox DC240/250 family however there are some agencies or independent providers operating these machines.

I still employ a Xerox DC242 at my agency and to be honest it still performs very well for the type of work it is intended for.

Moving on, in recent times my machine almost become limp, the console/screen froze. Initially I thought the machine may have just needed a hard reboot however nothing seemed to have worked. The display would be fine yet irresponsive if you touched anything.

Nonetheless, I started looking into this problem online and found it to be a very common issue. So much so, some poor individuals have even gone as far as replacing the whole unit. This problem is not specific to the DC240/250 family but other similar range Xerox machines also.

Anyhow there were discussions of recalibration, removing the screen and putting it through a naked flame and so forth. Collating all these "fixs" including some uber wacky ideas, I come to a solution which worked an absolute treat. Just bare in mind if your machine is not part of the DC240/250 family this fix should still work if it is a similar looking console.

So the first thing to try before having to dismantle the screen is try recalibration, "hey what do you have to lose". A lot of engineers refer to a pen at the back of the screen and no one seems to be able to find it. Well the screen has two removable cover which literally clip off. One on the pivot stem which clips off in half and another which covers the brack from the stem to the actual screen. If you remove this cover, you will see a small black stylus which can be used for the screen calibration. Since i found this after fixing the machine (i know L-O-L) I had already attempted a failed recalibration using a stylus from my graphic tablet.

Anyhow, have the machine switched off. Hold down 0,1 & 3 together and whilst held down or pressed (however you would like to say it) switch on the machine. Do not let go of the buttons. Let the machine boot and you should get a white screen with a black quadrant. According to the manual, where lines cross they should be marked P1, P2, P3 and so forth with a total of 9 points. Starting from the top left point and working across each row, you need to touch the points in order. Once the last point is touched, the screen should change with only 4 points showing. You need to randomly touch the points and hear a sound on each touch which should eventually unveil a submit button, however this was not the case for me. Had it appeared, the calibration should be successful however it didnt. So moving on...

Since my screen was irresponsive yet responsive in calibration mode which made no sense to me at all. I initially though it must be some technical/software issue however had nothing to lose so pulled the screen apart.

It is very easy to take apart and we shall first cover this:

So whilst the machine is switched off and preferably at the mains also (remember safety first :p), remove the cable that connect the printer to the screen, you only need to remove it from the screen end.

Remove the little plastic cover that exposes the bracket at the back on the screen/console (same cover i mentioned above which exposes the stylus)

Loosen the 4 screws holding the screen to the bracket. No need to totally remove as the screen will slide up and out anyway.

Once you have the screen free, remove the back casing. This should reveal circuitry tucked inside a metal casing.

Remove the screws that hold the front fascia and the cluster together. This should free everything inside the screen housing.

I went a few steps ahead separating the the UI from the actual LCD but thats jut me and besides I wanted to make sure nothing else needed looking at whilst I had it all open.

Now hear is the tricky part which you can get very wrong if you are not careful however in terms of what you need to do is very straight forward. You need to heat the edges of the UI which the narrow ribon cable is fused to the UI. Now initially when I read up on this, I made the assumption that due to varying environments, the UI may have gather moisture over time hence become irresponsive, but im not sure now as in calibration move the screen responded. So I cannot give a true understand of why this all happens however the fix works. Nonestheless, other people recommend using naked flames and I have come across two guys that have messed their UI up totally. So I would recommend an adjustable heat gun (which I used) or a decent hair dryer.

So the idea is to heat the edges enough that is warm to the touch but not overly hot. So work on each side a time, wand over the edge and before it cools, rub your finger down the side too. Do this several times per side. Just make sure you dont get it too hot. Once done, put it all back together again. Fix it to the step and remember to plug the cable back in (can always be forgotten)

Voila, screen should start responding again.

I know I should have taken photos whilst doing it but didnt cross my mind at the time as I was so anxious to make it work.

Sorry for waffling on so much, but it may come across useful to some poor soul out there that has this problem and that was looking at spending £200-300 for a new screen or circa £150 for a new UI.

If anyone wants to add their expertise to this topic please do so, if someone can also explain why this happens, it would also be good to know.

Happy Printing

What About Profitability?

What about Profitability?
Offset yields new advantages

Read All About It